[CRM 2011] RetrievePrivilegeForUser failed – no roles are assigned to user. Returned hr = -2147209463

Have you added the system account which is running the CRM App Pool in IIS as a new user to your Dynamics CRM organisation? 😦

The system crashes when you add an account that is running the CRMAppPool as a Microsoft Dynamics CRM user. This is a documented issue and this behavior is by design.

By default, when a CRM user is created in Microsoft Dynamics CRM, the user has no security roles. Because the CRM service account is mapped with the newly created user, the CRM service account cannot operate anything. Therefore, the system crashes.

See the next CRM support article

SOLUTION:

There may be several solutions, but the quickest one probably is the next one: remove your current organization and re-imported it again mapping all users except the corresponding system account that is running the CRMAppPool. When you remove the organization from Deployment Manager, it doesn’t delete the related database; it only removes it from CRM configuration, so that you can import it again with a new configuration.

More information is available in the “Services and CRMAppPool IIS application pool identity permissions” section of the Microsoft Dynamics CRM 2011 Implementation Guide

Advertisements

Posted on December 5, 2011, in CRM, CRM 2011 and tagged , . Bookmark the permalink. 1 Comment.

  1. I just want to say Thank you!!! I was so dumb and added the service account user which crashed CRM. Your solution was easy and fast.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: